ClassicPress Requirements

In this Guide we cover the minimal ClassicPress requirements, suggested setups and some important details to keep in mind when you switch over from any existing WordPress install, specially if you come from a WordPress version 5.0 or higher.

ClassicPress minimal requirementsLink to this section

  • PHP version 5.6 or higher, but below PHP 8 (compatibility works for PHP 8 are in progress).
  • MySQL version 5.0 or higher.

ClassicPress recommendationsLink to this section

  • PHP version 7.2 or higher, but below PHP 8 (compatibility works for PHP 8 are in progress).
  • MySQL version 5.6 or higher.
  • The mod_rewrite Apache module.
  • A link to ClassicPress.net on your website.
  • An SSL certificate to host your website using HTTPS (available for free from Let’s Encrypt and from most hosting providers).

If switching from a WordPress install 5.0 or HigherLink to this section

  • Make sure you are not using any Plugin that requires WordPress 5.0 or higher.
  • Maker sure you are not using a Theme that requires WordPress 5.0 or higher.
  • Make sure you are not using any code that uses WordPress functions introduced, or modified in or after WordPress 5.0.
  • Sometimes, you can proceed using above-mentioned Themes or Plugins, by providing “shims” for the missing Functions.