is_lighttpd_before_150()

Is the server running earlier than 1.5.0 version of lighttpd?


Return

(bool) Whether the server is running lighttpd < 1.5.0.


Source

File: wp-includes/functions.php

function is_lighttpd_before_150() {
	$server_parts = explode( '/', isset( $_SERVER['SERVER_SOFTWARE'] )? $_SERVER['SERVER_SOFTWARE'] : '' );
	$server_parts[1] = isset( $server_parts[1] )? $server_parts[1] : '';
	return  'lighttpd' == $server_parts[0] && -1 == version_compare( $server_parts[1], '1.5.0' );
}

Changelog

Changelog
Version Description
WP-2.5.0 Introduced.